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Lecture 4: Overview

« Assignment 2

« System-on-Chip Design with SpecC
— Top-down Design Methodology
— Refinement-based System Design Flow
— System-on-Chip Environment (SCE)
— Interactive Demonstration

« Assignment 3
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Assignment 2

1. Practice SpecC Tools
— Setup
e source /opt/sce-20080601/ bi n/ setup. csh
— Examine simple examples
e nkdir sinple_tests
e cd sinple_tests
* cp $SPECC/ exanpl es/ si nple/*
e Is
e vVvi Hellowrld.sc
— Practice the compiler
e man scc
e scc HelloWwrld —-sc2out —vv -ww
— Practice the simulator
e ./HelloWrld
— Practice the tools
e nman sir_tree
e scc Adder -sc2sir -o Adder.sir
e sir_tree -bt Adder.sir FA
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Assignment 2

2. Convert JPEG Encoder application into SpecC Model
Version 0

*  Compile JPEG Encoder with SpecC compiler
* scc jpegencoder.sc —vv -ww

— Version 1

* Introduce test bench
—  Stimulus behavior (ReadBnp)
— Design-under-Test behavior (JPEGencoder)

» Seq. child behaviors (DCT1, DCT2, Quant i ze, Zi gzag, Huf f nan)

» Communication through variables mapped to ports
— Monitor behavior (Di f f Gol den)
— Version 1.1
* Add timing to test bench
— Print encoding time for each block (in Stimulus and/or Monitor)
— Version 2.0
* Create a parallel model
— Change DUT execution to ‘par { }’
— Change communication to typed doubl e_handshake channels
— Version 2.1

» Create a pipelined model
— Change communication to typed queue channels
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Top-down Design Methodology
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Refinement-based System Design Flow
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Refinement-based System Design Flow

« Step 1: Architecture Refinement

— Allocation of Processing Elements (PE)
» Type and number of processors
» Type and number of custom hardware blocks
» Type and number of system memories

— Mapping to PEs
* Map each behavior to a PE
* Map each channel to a PE
* Map each variable to a PE

— Result;
System architecture of concurrent PEs
with abstract communication in channels
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Refinement-based System Design Flow

» Step 2: Scheduling Refinement

— For each PE, serialize the execution of behaviors
to a single thread of control
— Option (a): Static scheduling
» For each set of concurrent behaviors,
determine fixed order of execution

— Option (b): Dynamic scheduling by RTOS
» Choose scheduling policy,
i.e. Round-robin or priority-based
» For each set of concurrent behaviors,
determine scheduling priority
— Result:
System model with abstract RTOS scheduler
inserted in each PE
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Refinement-based System Design Flow

» Step 3: Communication Refinement

— Allocation of system busses
» Type and number of system busses
» Type of bus protocol for each bus (if applicable)
* Number of transducers (if applicable)
» System connectivity
— Mapping of channels to busses

* Map each communication channel to a system bus
(or multiple busses, if applicable)

— Result:
Bus-functional model of the system
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Refinement-based System Design Flow

+ Step 4: Hardware Refinement (for HW PE)

Allocation of Register Transfer Level (RTL) components
» Type and number of functional units (e.g. adder, multiplier, ALU)
» Type and number of storage units (e.g. registers, register files)
» Type and number of interconnecting busses (drivers, multiplexers)
Scheduling
» Basic blocks assigned to super-states
« Individual operations assigned to states (clock cycles)
Binding
» Bind functional operations to functional units
* Bind variables to storage units
» Bind assignments/transfers to busses
Result:
Clock-cycle accurate model of each HW PE
Output: Synthesizable Verilog description
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Refinement-based System Design Flow

« Step 5: Software Refinement (for SW PE)

— C code generation
» For selected target processor

— RTOS targeting
 For selected target RTOS

— Compilation to Instruction Set Architecture
« for Instruction Set Simulation (ISS)

— Assembly

— Result:
Clock-cycle accurate model of each SW PE

— Output: downloadable binary image
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System-on-Chip Environment (SCE)

* Integrated Development Environment (IDE)
with support of:

Graphical frontend (sce, scchart)
— SLDL-aware editor (sced)
— Compiler and simulator (scc)
— Profiling and analysis (scpr of )
— Architecture refinement (scar)
— RTOS refinement (scos)
— Communication refinement (sccr)
— RTL refinement (scrtl)
— Software refinement (sc2c)
— Scripting interface (scsh)
— Tools and utilities ...
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System-on-Chip Environment (SCE)
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SCE Main

Window

25V ocaderarch.sir
B2 VocoderComm.sir
[ YocoderRTL sir

L vocoderimpl.sir

FPre_Process
Coder_T2ke
GCoder Tehe. Seq T
1P Anziysis

es
Subirames_imt
Subirames_Eody i
Glosed_Loop
Subipanes_ Bodye
Codteiiook_C
LUpdate
Subfames_Ed
St Sigrals

B § post process Posi_Frocess

[ A4 monitor Manitor

L@ stimuius Stimulus

Hierarchy

- Computation

Narme: Type N gﬁ;@

& Open_Loop 163 267413
[-& syn_filter Syn_Filt 3912 5226
& residual Residu 1356 5777
(8ol lag_estimate OI_Lag_Est 163 222092
& for_init Open_Loop_Init 163 0
& for_end Open_Loop_End 652 81
[ & for_bodyz Open_Loop_Bodyz 652 244
(& for_body1 Open_Loop_Body1 652 1
b @wsp_i short int [40]

b @p_spesshi  shortint™

b @men_w short int [10]
Foi int

b oat short int [11]

F oan2 short int [11]

L @apt short int [11]

P wsp inout short int *
o bt ot in unsigned bitfs:0]

Output: "VocoderSpec.o’
Linking.
Input: “vocederSpec.o”
Quiput: " ocoderSpec”
Dene.

Ready
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25V ocaderarch.sir
[&VocoderComm.sir

SCE Source Editor

S

Hord1é speech_proc[L_FRAME].

[ YocoderRTL sir
L vocoderimpl.sir

[ A4 monitor speadiy
L@ stimuius

Mord16 old_speechL_TOTAL],
Mord16 #speech.
ot Hord16 =e_uindou.
Mord16 old_use[L_FRAME + PIT_MAX1,
out Hord16 *usp.
Marel16 old_exc[L FRAME + PLT_MAX + L_INTERPOL].
out Hordl6 =exe.
out Flag  pteh,
out DTHeEr] txetx_ctrl,
in Flag  reset_flag

inplenents Ireset

woid imit{vaid)

Initialize pointers to speech westor.

o § post process

old_speech + L_TOTAL - L_FRAME:  /* New spesch =/
pwirdou = old_speech + L_TOTAL - L_WINDOW: /= For LPC window =/

/% Initialize pointers =/

usp = old_usp + PIT_MAX:
exc = old_exc + PITMAK + L_INTERFOL:

/% vectors to zero %/

MO VOCOUETSREE o
Output: "VocoderSpec.o’
Linking.
Input: “vocederSpec.o”
Quiput: " ocoderSpec”
Dene.

Set._zero {old_speech. L_TOTAL}:
Set_zero (old_exs, PLT_MAX + L_INTERPOL):
Set_zero (old_wsp. PIT_MAM):

txdts_ctrl = TH_SP_FLAG | TX_VAD_FLAG:
pteh = 12
3
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SCE Hierarchy Displays
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SCE Compiler and Simulator

IEI=TES

Eile Edt View Eroject Synthesis Validation Windows

Help

e Bd 8

- VocoderRTL sir

L vocoderimpl.sir Version 1.

European digital cellular telecommunications systen
12200 bits/s speech codso for

enhanced full rate speech traffic channels

Bit-Exact SpecC Simulation Code - encoder

Harch 13, 1333

£ subizmes
A ror it Mz disabled
A ror_voay T Input speech file: speechfiles/spch_unx.inp
dciseq food| | TPUt bitstrean Filer nodtc.bit o
Ao 0002 || leranes 1 encading delay = 0.0
rcoaetook d| |frane= 2 encoding delay = 6.00 ns 1
Madsls B § cprate Franc= 3 encoding delay = .00 ns
2 tor st Frane= 4 encoding delay = 6,00 ns
E franc= 5 encoding delay = .00 ns
A Compile frane= & encoding delay = 0,00 ms
— e e | [frone= 7 encoding delay = 9,00 ns
sct: SpecC Compller V 222 frane= & encoding delay = 0,00 ns
() 1997-2002 CECS, University of California, Irvine frane= 9 encoding delay = 8100 ns
frane= 10 encoding delay = 0,00 me
frane= 11 encoding delay = 6100 ns
liaportinge v Fr-ane= 12 encoding delay = 0,00 ns
{aput: v pcodersparine i Frane= 13 encoding delay = 0.00 ms
Output: <internal representation> frane= 14 encoding delay = 0,00 ns
Translating Frane= 15 encoding delay = 6200 ns
- - Franz= 16 encoding delay = 0,00 s
Inputzsintomalitapresentetion; frane= 17 encoding delay = 000 ns
Dlitput-yetde fopecin. franc= 18 encoding delay = 0,00 ns
Output: "V ncoderspec.ce! frane= 13 encoding delay = 6,00 ns
Compiling franc= 20 encoding delay = .00 ns
5 % frane= 21 encoding delay = 0,00 me
Do oo ke L
P P frane= 23 encoding delay = 0,00 me
Llpking frane= 24 encoding delay = 0.00 ms
Input: “vocederSpec.o” frane= 25 encoding delay = 0,00 ns
Qutput: “Vocoderspect franc= 26 encoding delay = 8,00 ns
Bane! | [prane= 27 encoding delay = 0,00 ns
eady

EECS222C: SoC Software Synthesis, Lecture 4

Copyright © 2003 CECS 17

SCE Profiling and Analysis

IEI=TES

Window View Arrange

Help

Operation Profile

Rel. seconds

Computation
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6617

Tupe.

code Q_Gain_Code 652 1250
[upc_sh  Ex_Syn_Upd_sh 652 7367
i =Bl

10w
gm
Sm
am]
Zm
O Gampuetion Conputation Computaton
Ip_analysis clased_loop codeboak_cn

Analyze

Int ALU
[second:
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Int Arith
[seconds]

Enerating e al data STTCTire Tor proTiig

Deriving raw statistics fram SIR file

Computing weighted statistics R

Annotating weighted statistics to SIR file |

End: retargetable profiling
codebook_cn

[Feaay. 2|
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Interactive Demonstration

» Design example: GSM Vocoder
— Enhanced full-rate voice codec
* GSM standard for mobile telephony (GSM 06.10)
» Lossy voice encoding/decoding
» Incoming speech samples @ 104 kbit/s
» Encoded bit stream @ 12.2 kbit/s
» Frames of 4 x40 = 160 samples (4 x 5ms = 20ms of speech)
— Real-time constraint:

* max. 20ms per speech frame
(max. total of 3.26s for sample speech file)

— SpecC specification model
» 29 hierarchical behaviors (9 par, 10 seq, 10 fsm)
» 73 leaf behaviors
* 9139 formatted lines of SpecC code
(~13000 lines of original C code, including comments)
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Assignment 3

1. Become familiar with the System-on-Chip Environment (SCE)
— Setup
* Note that we will use the 2004 version of SCE for the tutorial:
source /opt/sce-20041007/ bi n/ setup. csh
rm-rf ~/.sce
nkdi r deno
cd deno
set up_deno
— Open the SCE Tutorial document
e acroread SCE Tutorial/sce-tutorial.pdf &

» To protect the environment and save some trees,
please do not print the tutorial document!
It contains 250 pages and you will likely read it only once... ;-)
— Follow the SCE Tutorial instructions
e sce &

— Cleanup
* When done (or to start over), clean up your demo directory
e cd ..
e rm-rf deno
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Assignment 3

2. Simulate your JPEG Encoder model in SCE
— Setup
Note that we will use the 2008 version of SCE for the JPEG Encoder:
source /opt/sce-20080601/ bi n/ set up. csh
rm-rf ~/.sce
cd j pegencoder
sce
— Create a new project in SCE
e Project->New
e Project->Settings
— Set verbosity level to 3 and warning level to 2
— Adjust any other options the compiler may need to compile your model
e Project->SaveAs “j pegencoder.sce”
— Load your design model into SCE
e File->Inport “jpegencoder.sc”
e Project->AddDesi gn
* Right-click on j pegencoder. sir in the project window, and
Renane the model to JPEGencSpec
— Compile and simulate your model in SCE
e Validation->Conpile
* Validation->Sinulate

EECS222C: SoC Software Synthesis, Lecture 4 (c) 2008 R. Doemer 21

Assignment 3

3. Analyze your JPEG Encoder model in SCE

— Setup
« ...continued from step 2 (previous page)

— View the structural hierachy chart
= Select the Mai n behavior in the behavior browser
* Right-click - >Chart
* Double-click the chart to add a level of hierarchy
e View >Connectivity

e Wndow >Print...tofile “j pegencoder. ps”
» Deliverables
— SpecC source file

e “jpegencoder.sc”
— Hierarchy chart
* “jpegencoder. ps”
* Due

— by Friday, Oct 24, 2008, at noon
— by email to doener @ici . edu with subject “EECS222C HW3”
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