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Lecture 6: Overview

+ System-on-Chip Design Flow
— Top-down design methodology
— Refinement-based design flow
 Architecture and Scheduling
» Communication
* Implementation

— Hardware synthesis
— Software generation

» System-on-Chip Environment (SCE)
— Interactive Demonstration
— Design Example: GSM Vocoder

* Homework Assignment 3
— Discussion, Q&A

* Homework Assignment 4
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Top-Down SoC Design Flow
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SCE Design Methodology

* Four levels of abstraction

— Specification model: untimed, functional

— Architecture model: estimated, structural

— Communication model: timed, bus-functional
— Implementation model: cycle-accurate, RTL/IS

» Five data bases
— Algorithms for specification
— Components for architecture
Busses for communication
RTOS for SW
RTL components for HW

» Three refinement steps
— Architecture refinement (Specification -> Architecture)
— Communication refinement (Architecture -> Communication)
— Cycle-accurate refinement (Communication -> RTL/IS)
« HW/ SW /interface synthesis
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Refinement-based System Design Flow

« Step 1: Architecture Refinement

— Allocation of Processing Elements (PE)
» Type and number of processors
» Type and number of custom hardware blocks
» Type and number of system memories
— Mapping to PEs
* Map each behavior to a PE
* Map each channel to a PE
* Map each variable to a PE
— Result:
System architecture of concurrent PEs
with abstract communication in channels
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Refinement-based System Design Flow

« Step 2: Scheduling Refinement

— For each PE, serialize the execution of behaviors
to a single thread of control
— Option (a): Static scheduling
» For each set of concurrent behaviors,
determine fixed order of execution

— Option (b): Dynamic scheduling by RTOS
» Choose scheduling policy,
i.e. Round-robin or priority-based
» For each set of concurrent behaviors,
determine scheduling priority
— Result:
System model with abstract RTOS scheduler
inserted in each PE

EECS222A: SoC Description and Modeling, Lecture 6 (c) 2009 R. Doemer 7

Refinement-based System Design Flow

« Step 3: Communication Refinement

— Allocation of system busses
* Type and number of system busses
» Type of bus protocol for each bus (if applicable)
* Number of transducers (if applicable)
» System connectivity
— Mapping of channels to busses

* Map each communication channel to a system bus
(or multiple busses, if applicable)

— Result:
Bus-functional model of the system

EECS222A: SoC Description and Modeling, Lecture 6 (c) 2009 R. Doemer 8

(c) 2009 R. Doemer

Lecture 6



EECS222A: SoC Description and

Modeling

Refinement-based System Design Flow

+ Step 4: Hardware Refinement (for HW PE)

— Allocation of Register Transfer Level (RTL) components
» Type and number of functional units (e.g. adder, multiplier, ALU)
» Type and number of storage units (e.g. registers, register files)
» Type and number of interconnecting busses (drivers, multiplexers)
Scheduling
» Basic blocks assigned to super-states
« Individual operations assigned to states (clock cycles)
Binding
» Bind functional operations to functional units
« Bind variables to storage units
» Bind assignments/transfers to busses
Result:
Clock-cycle accurate model of each HW PE
Output: Synthesizable Verilog description
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Refinement-based System Design Flow

« Step 5: Software Refinement (for SW PE)

— C code generation
* For selected target processor

— RTOS targeting
* For selected target RTOS

— Compilation to Instruction Set Architecture
« for Instruction Set Simulation (ISS)

— Assembly

— Result:
Clock-cycle accurate model of each SW PE

— Output: downloadable binary image
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System-on-Chip Environment (SCE)

* Integrated Development Environment (IDE)

h support of:

Graphical frontend (sce, scchart)
SLDL-aware editor (sced)

Compiler and simulator (scc)

— Profiling and analysis (scprof)

— Architecture refinement (scar)

— RTOS refinement (scos)

— Communication refinement (sccr)
— RTL refinement (scrtl)

— Software refinement (sc2c)

— Scripting interface (scsh)

— Tools and utilities ...
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System-on-Chip Environment (SCE)
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SCE Synthesis Engine
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SCE Main Window

Synthesis Validation Windows Help

Computation | Da!
[cycles] [ct
& Open_Loop 163 267413
L& sun_filter Syn_Filt 3912
wnocoderRTL sir - ke & residual Residu 1956
Lvocaderimpl sir g Coder_12k2_Seq1 |- & 0l_lag_estimate OI_Lag_Est 183

1P Analysis b & for_init Open_Loop_nit 163
Yo — 1 &pfor_end Open_Loop_End 652
Subfemes It -8 for_body2 Open_Loop_Body? 652
- & for_body1 Open_Loop_Bodyl 652
L gusp_i short int [40]
Subzmes_8o b ep_spesch_i  shortint®

£ corebook_crr Coehoni_CiV L gmemn_w shortint [10]

b1 ol int

v s_&
W shit_signals  Shit_Signals eaLl snortint[1]
& ¥ oost process Fost_ Process o2 shortint [11]

(AF monitor Monitor shartint [11]
L@ stimuius Stimulus inout shatt int *
P bt ctn in unsigned bitfs:0]

S

Natie Type | N

for_erd

& g | Analyee | Refine | shel |
[ TWpot vocoderspecce
Output: "VocoderSpec.o’
Linking.
Input: “vocoederSpec.o”
Quiput: " ocoderSpec”
Done.

[Ready
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SCE Source Editor

Eile Edit Wiew Project Synthesis Validation Windows

REIEEIEEXES : Eile Edit

behauior Coder_12k2_Seq1(

View

in Word1é speech_proc[L_FRAME],
Word16é old_speech[L_TOTAL],
Mord16 *speech.

out Mordlé *p_uindou,

PrE_process Mord16 old_usp[L_FRAME + PIT_MAX].

coder_T2h2 out Mord16 =usp.

A seq7 Mord16 old_exc[L_FRAME + PLT_MAX + L_INTERPOLI.

b ip_anals: out, Mord16 =exc.

out Flag  phoh.

ot DTHetr] bxotix_ctrl,

in Flag reset_flaz

:

[V ocoderComm.sir
B VocoderRTL sir
Lvocoderimpl sir

inplenents Ireset

void indt(uoid)

& upaate

A o _en

gt o . Initialize pointers to speech vestor.
8 post_process

[/ monitor speech = old_speech + L_TOTAL - L_FRAME: /= New speech =

A stimulus p_window = old_speech + L_TOTAL - L_WINDOW; /= For LPC window =/

=)
Hisrarchy

/% Initialize pointers */

usp = old_wsp + PIT_MAN:
exc = old_exe + PIT_MAN + L_INTERPOL:

Models

/% vectors to zero =/

A Conpile | Refine | shell | Set_zero (old_speech. L_TOTAL):
MpUL WOCoderspec.co - | Set_zero (old_exc. PIT_MAX + L_TNTERPOL):
Qutput: "Vocoderspec.o” Set_zero {old_wsp. PIT_MAK):
Linking

Input. “VocaderSpec.o"

txetx_ctrl = TH_SP_FLAG | TH_VADFLAG:
Output: "VocoderSpec” Ptoh = 12

Done. =
[INS [Line: 62 Col: 8
[Ready
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SCE Compiler and Simulator

File Edit view Project Synthesis Validation Windows

European digital cellular telecommunications systen
12200 bits/s speech codec
enhanced full rate speech traffic channels

[V ocoderComm.sir
B VocoderRTL sir
Lvocoderimpl sir

coder_12k2
W seq

2 anaysis

Bit-Exact Specl Simulation Cade - enceder
Version 1.
Harch 13, 1939

B
- subrames

A or it e disabled

A o o T Input speech file; speechfiles/speh_unx, inp

E3cioed fooy| | Dutput bitstrean File:  nodvx,bi

A for_ody? encoding delay
D codenook_ encoding delay
1 upetate

2 Compile

sce: SpecC Compiler V 222
(c) 1987-2002 CECS, University of Califarnia, Irvine

encoding delay
encoding delay
encoding delay = 0,00 ns

Importing...
Input. “Vocederspes.ins.sir
Output: <intemal represertation=

Translating
Input: <internal representations z:ggg;:e ﬂZ%ZH 8 o
Qutput: "VocoderSpec.h" Emdmg dglag o0
Output: "VocoderSpec.cc” encoding delay = 0,01

Compiling encoding delay
Input: "VocoderSpec.cc” Z:zgg::; gz%z: g g
Qutput: “Vocoderspec.o” it i

Linking, encoding delay = 0,01
Input. “VocaderSpec.o" encoding delay = 0.0
Output: *Vocoderspect encoding delay = 0,0

Done encoding delay = 8,00 ns

[Ready
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MWindow Customize
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Generating mlemal dala sTCTre for proming
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End: retargetable profiing

codebook _

codehook_cn

[Ready
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SCE Application Design Example

GSM Vocoder
— Enhanced full-rate voice codec
GSM standard for mobile telephony (GSM 06.10)
Lossy voice encoding/decoding
» Incoming speech samples @ 104 kbit/s
» Encoded bit stream @ 12.2 kbit/s
* Frames of 4 x 40 = 160 samples (4 x 5ms = 20ms of speech)
Real-time constraint:

* max. 20ms per speech frame
(max. total of 3.26s for sample speech file)

SpecC specification model
29 hierarchical behaviors (9 par, 10 seq, 10 fsm)
» 73 leaf behaviors

* 9139 formatted lines of SpecC code
(~13000 lines of original C code, including comments)
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» Design Example 1: GSM Vocoder
Simulation Speed Code Size
100000 » 20000
o / o
£ 10000 £ 15000 .
5 1000 4 /
K S 10000 +———=—
5 100 3
E E 5000
o 10 S
z
= 1 . / . 0 . . .
Spec  Arch  Comm  Impl Spec Arch Comm Impl
Refinement Effort
Modified Manual Automated
lines User / Refine
Spec — Arch 3,275 3~4 month 15 min/<1 min
Arch - Comm 914 1~2 month 5 min/ < 0.5 min
Comm — Impl 6,146 5~6 month 30 min / < 2 min
Total 10,355 9~12 month 50 min / <4 min
* Productivity gain: 12 months vs. 1 hour = 2000x !
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» Design Example 2: JPEG Encoder
Simulation Speed Code Size
1000000 3500
@ 100000 - @ 3000
E 10000 E 2500 //
® 1000 5 2000 ———5—
2 100 5 1500
§ o £ 1000
3 500
= 1 o / T = 0 r T T
Spec Arch Comm Impl! Spec Arch Comm Impl
Refinement Effort
Modified Manual Automated
lines User / Refine
Spec — Arch 751 1~2 month 5 min /< 0.5 min
Arch - Comm 492 ~1 month 3 min /< 0.5 min
Comm — Impl 1,278 3~4 month 20 min/ <1 min
Total 2,521 5~7 month 28 min / <2 min
* Productivity gain: 6 months vs. 1/2 hour = 2000x !
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Project Discussion

+ Digital Camera Example
— Component Model

CCD SoC Flash

Sensor Memory
CCD pixel Jpeg bytes File
ConUoI Encoder 1/0

JpegEncoder
Pixel Read ]ﬁfk{ DCT ]W-[Quam]m{ Huff bytes
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Homework Assignment 3

e Task

— Convert JPEG Encoder Application
to a proper SpecC Specification Model

Main

'
Stimulus| -+ 1 | Monitor

ReadBmp() FileWrite()

» Deliverables
— Email to doemer@uci.edu with subject
“EECS222A Assignment 3”
« Brief status description (in body of your email)
» Source code jpegencoder.tar.gz (attachment)
* Due
— Next week: October 30, 2009, 12pm (noon)
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Homework Assignment 3

Hint:
— Use the sir_tree tool to validate your hierarchy
— The final model should look like this:

QO WWwWwwwowwwowowowow
L L S T T SO P P T
HFHHHHHHHFODHKFKF®BO

io behavior Main

| ====== JpegEncoder jpeg
| |-—==-- Dct dct

| I |-=—==== Bound bound

| | | ===—=== ChenDct chendct

| | \-————- Preshift preshift

| | =====- Huff huff

| I | —————- Huffencode huffencode
| | \=ommms Zigzag zigzag

| | === Quantize quantize

| \--=--=-=- ReadBlock readblock

|--—=-- Monitor monitor

|-=—==-= Stimulus stimulus

| === c_queue data

\-——-—-—- c_handshake start

doemer@epsilon.eecs.uci.edu:3 > sir tree -blt digicam.sir
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Assignment 4
1. Become familiar with the System-on-Chip Environment (SCE)
— Setup
» Note that we will use the 2003 version of SCE for the tutorial:
* source /opt/sce-20030530/bin/setup.csh
e« rm -rf ~/.sce
¢ mkdir demo
¢ cd demo
* setup demo
— Open the SCE Tutorial document
* acroread SCE_Tutorial/sce-tutorial.pdf &
* Please do not print the tutorial, it contains 250 pages!
— Follow the SCE Tutorial instructions
until the architecture model is successfully created (page 94)
* sce &
— Cleanup
*  When done (or to start over), clean up your demo directory
e cd ..
e rm -rf demo
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Assignment 4

2. Simulate your digital camera model in SCE
— Setup

Note that we will use the 2008 version of SCE for the JPEG Encoder:

* source /opt/sce-20080601/bin/setup.csh
e rm -rf ~/.sce
¢ cd jpegencoder2
* sce
— Create a new project in SCE
* Project->New
¢ Project->Settings
— Set verbosity and warning levels to 2
— Adjust any other options the compiler may need to compile your model
¢ Project->SaveAs “digicam.sce”
— Load your design model into SCE
¢ File->Import “digicam.sc”
¢ Project->AddDesign
* Right-click on digicam.sir in the project window, and
Rename the model to DigicamSpec
— Compile and simulate your model in SCE
¢ Validation->Compile
¢ Validation->Simulate
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Assignment 4

3. Analyze your digital camera model in SCE
— Setup
» ...continued from step 2 (previous page)
— View the structural hierachy chart
» Select the Main behavior in the behavior browser
* Right-click ->Chart
* Double-click the chart to add further levels of hierarchy
» Turn on connectivity View->Connectivity
¢ Window->Print.. tofile “digicam.ps”
* In your shell window, convert the PostScript file to PDF:
ps2pdf digicam.ps
* Check the PDF file: acroread digicam.pdf
* Deliverables
— Hierarchy chart
e “digicam.pdf”
* Due
— by Friday, Nov 6, 2009, at noon
— by email to doemerQuci.edu with subject “EECS222C HW4”
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